AstinaGT Forums

AstinaGT Forums (http://www.astinagt.com/forums/index.php)
-   Suspension & Wheels (http://www.astinagt.com/forums/forumdisplay.php?f=8)
-   -   SP20 Front strut top mount (http://www.astinagt.com/forums/showthread.php?t=22191)

lankykiwi 22-04-2017 11:51 AM

SP20 Front strut top mount
 
Gidday all, I'm in New Zealand and have a fantastic Red 2001 SP20, excellent cars, when they work!

It's been clunking and squeaking over bumps so I did my research and concluded it was the top mounts for the front struts. Today I got a mount and bearing from a local supplier and whipped the strut out, easy as!

However, the mount I bought and the mount that was in the car are different!
Left is the original mount, bearing and top cap, right is the new mount and bearing.

Keep in mind the supplier used both my rego and the make/model/year to select these parts, so they should be the same right?

http://i.imgur.com/ihlunwP.jpg

My question is, can I use the new mount, or should I go back on Monday and throw it at the monkey behind the counter? The car is in bits at the moment, so any help would be awesome!

project.r.racing 30-04-2017 08:12 PM

Although different, it looks like it will do the same job. Both bearings have the same inner hole size to fit the upper spring hat.

The newer one is probably just a re-engineered/updated version.


All times are GMT +10. The time now is 06:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
2001- 2010 AstinaGT