Go Back   AstinaGT Forums > Performance & Technical > Audio Hi-fi

Reply
 
Thread Tools Display Modes
Old 20-02-2010, 06:57 PM   #1
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
Question My SP20 HU is playing up

Hey folks,

Today my SP20 HU CD player stacker has carked it...
I think I have a CD jammed in the player....
Currently i have 6 cd's in the HU and I cannot eject a cd from the unit...
Radio is working but the CD player is not...

Currently at the moment it is just flashing on CD 2 and the eject button whe pressed is not responding. Normally the "OUT" message comes up on the sreen and you can hear the HU ejecting the CD.
When you press the eject button nothing is happening and the disc 2 symbol just flashes....

Has anyone experienced this and what they did to recity / fix?
will i need to get the whoel HU out and pull the unit apart to get the CD's out?

I have been reading the sticky thread of HU removal for the SP20
but dont want to do this if there is an easier solution


Cheers

Brad
bradsp20 is offline   Reply With Quote
Sponsored Links
Old 20-02-2010, 08:34 PM   #2
Brisbane_boy
Senior Member
 
Brisbane_boy's Avatar
 
Join Date: Mar 2009
Location: Brisbane QLD
Car: 2002 323 astina
Posts: 1,059
sounds like time to upgrade!

i never had the cd stacker so i cant help u there sorry.
__________________


If your not allowed to go fast, you might as well look fast
Brisbane_boy is offline   Reply With Quote
Old 20-02-2010, 08:42 PM   #3
marcs_sp20
Moderator
 
marcs_sp20's Avatar
 
Join Date: Oct 2005
Location: Ipswich, Queensland
Car: 2002 Mazda Astina SP20 2006 Mazda 6 GY Wagon
Posts: 9,767
have you tried disconnecting/re-connecting the battery? Honestly wouldnt have a clue, as its been 3 years since I had the oem stacker in the car
__________________
[URL="http://www.astinagt.com/forums/vbpicgallery.php?do=view&g=590"]
marcs_sp20 is offline   Reply With Quote
Old 20-02-2010, 09:48 PM   #4
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
cheers fellas... ill disconnect the battery and try...
what happened i was in the middle of a cd playing and then the stacker starting making a mid screaching noise... i turned it off then on and then tried to eject the cd and wont respond....
bradsp20 is offline   Reply With Quote
Old 22-02-2010, 01:49 AM   #5
arden
Senior Member
 
arden's Avatar
 
Join Date: Mar 2003
Location: Sydney
Car: Suby
Posts: 1,280
Disconn Battery or hold down the eject button!
hope it works out for ya mate!
__________________
arden is offline   Reply With Quote
Old 23-02-2010, 10:39 AM   #6
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
Have done and still doesnt work..
Pulled out the HU and got the 1st CD out... re plugged the HU back in and still the CD stacker of the HU doesnt work...
Im contimplating taking the stacker apart and retrieve all other 5 discs and see if that makes a difference... if not outsource a cheap replacement...
bradsp20 is offline   Reply With Quote
Old 23-02-2010, 11:04 AM   #7
Mad Mat
HONEYWELL REPRESENT
 
Mad Mat's Avatar
 
Join Date: Aug 2005
Location: Salisbury - Inner City
Car: 1997 BA Hardtop - Had a 2003 BJii J48 Sport20, and 2x bg SOHC astina hatches
Posts: 5,006
Send a message via MSN to Mad Mat
did u do anywork on ur sterio lately. this is what happen to mine ages ago. i put in a sub. and then CODE came up on the display. so i entred in the last digets of my vin number (as told by mazda) and it came back to life. but still no cd player. i don't get it. it just failed

so long story short mate. i've been there and u just need to replace it
__________________

1994 323 BG Hatch 2005-2007 Crashed into truck
1991 323 BG Hatch 2007-2008/9 SOLD
2003 BJ SP20 J48 Hatch 2008-2011 Regretfully SOLD
1997 BA I4 Sedan 2012-CURRENT
1985 BF 323 Hatch 2014-2015
SOLD
1989 MX5 2015-2015
Mad Mat is offline   Reply With Quote
Old 23-02-2010, 12:47 PM   #8
marcs_sp20
Moderator
 
marcs_sp20's Avatar
 
Join Date: Oct 2005
Location: Ipswich, Queensland
Car: 2002 Mazda Astina SP20 2006 Mazda 6 GY Wagon
Posts: 9,767
Not sure if this will help:
http://www.floptical.net/mazda/service_web/09-02B.PDF

If you need to replace, talk to orion, as he found a loom from over in the states... if only I knew that when I replaced mine
__________________
[URL="http://www.astinagt.com/forums/vbpicgallery.php?do=view&g=590"]
marcs_sp20 is offline   Reply With Quote
Old 25-02-2010, 07:00 AM   #9
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
Thanks Fellas for the advice...
I tried pulling the cd stacker apart on wed night and re installed again...
No luck again... radio works but the CD Player doesnt... i suspect the motor etc in the player has carked it.... cant even hear the cd player wanting to work...
I have scored myself a 2nd hand genuine HU off ebay... ill be installing on the weekend...
was the cheapest and still make it stock original at this stage...
bradsp20 is offline   Reply With Quote
Old 25-02-2010, 04:16 PM   #10
andrewck
Junior Member
 
andrewck's Avatar
 
Join Date: Mar 2008
Location: Alstonville
Car: Ford Focus LV XR5
Posts: 196
Mine died 8 mths ago I just listen the radio these days time for a new car anyway
andrewck is offline   Reply With Quote
Old 08-03-2010, 05:51 AM   #11
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
Cheers Andrewck
after 2 weeks without a CD player... i cracked it...
on the weekend got Strathfields to install a Sony Explode HU...
DOOF DOOF is back...
bradsp20 is offline   Reply With Quote
Old 08-03-2010, 11:37 AM   #12
so fresh
Senior Member
 
so fresh's Avatar
 
Join Date: May 2009
Location: tullamarine,melbourne
Car: 92 astina 323 bg & 01 SP20
Posts: 660
lol good work mate lasted longer than me how much they charge for the install and what else did they install?
__________________
oh you hit my spot!
so fresh is offline   Reply With Quote
Old 08-03-2010, 11:42 AM   #13
marcs_sp20
Moderator
 
marcs_sp20's Avatar
 
Join Date: Oct 2005
Location: Ipswich, Queensland
Car: 2002 Mazda Astina SP20 2006 Mazda 6 GY Wagon
Posts: 9,767
Quote:
Originally Posted by bradsp20 View Post
Cheers Andrewck
after 2 weeks without a CD player... i cracked it...
on the weekend got Strathfields to install a Sony Explode HU...
DOOF DOOF is back...
I thought you bought one off ebay?
__________________
[URL="http://www.astinagt.com/forums/vbpicgallery.php?do=view&g=590"]
marcs_sp20 is offline   Reply With Quote
Old 09-03-2010, 05:03 AM   #14
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
Quote:
Originally Posted by so fresh View Post
lol good work mate lasted longer than me how much they charge for the install and what else did they install?
Hey mate
just got a SOny Xplode HU installed with Aux Input...
Head unit fully installed cost me all up $200.00

I didnt get any thing else installed... just that....
bradsp20 is offline   Reply With Quote
Old 09-03-2010, 05:05 AM   #15
bradsp20
AstinaGT Regular
 
bradsp20's Avatar
 
Join Date: Feb 2005
Location: Sans Souci
Car: sp20
Posts: 468
Send a message via MSN to bradsp20
Quote:
Originally Posted by marcs_sp20 View Post
I thought you bought one off ebay?
Yeah mate..the deal was ended up getting a 2nd hand HU stacker through Ebay from ForMaz Parts Plus in Smithfield...
When i got it 2 weeks ago i installed it and noticed the CD player was making noises and wouldnt work.. again radio worked but not the CD player...
Took the unit out again and unscrew the top cover... only to find that previous owners cds x 6 were still in the player... Summer Hits 2006
having to noticed a poor cd choice in the unit... I took it back and got refund....
after a week of driving with my original stock HU back in for the radio I cracked it... couldnt handle radio anymore and did a detour into Stratty
bradsp20 is offline   Reply With Quote
Old 28-10-2016, 10:12 AM   #16
Mr_Bone
Junior Member
 
Join Date: Oct 2016
Location: Gold Coast, QLD Australia
Car: 2002 Mazda 323 SP20 Astina
Posts: 2
Hey,
I just picked up my new SP20 yesterday and am having the same issue
it has one cd and has played it but cant get it to change back to it or accept another disc
HELP?!
Mr_Bone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 09:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
2001- 2010 AstinaGT